User Registration
The NuCaptcha API requires the PHP mcrypt module.